Firefox frissítés után nem működő bővítmények

Goosfrabaa küldte be sze, 2011-09-28 10:06 időpontban

Feltetted a legfrissebb Firefoxot, de a bővítményeid (extensions) nem kompatibilisek vele?

A megoldás (amíg kijön a hivatalos verzió) mindössze annyi, hogy át kell írni a bővítmény(ek) kompatibilitási verzióját:

  1. Azonosítsd be a "hibás" bővítmény könyvtárának helyét valahol a ~/.mozilla/firefox/*.default/extensions/ alatt
  2. Keresd meg benne az install.rdf fájlt és nyisd meg egy egyszerű szövegszerkesztővel
  3. Keress Firefox szekciót, amiben szerepel a maxVersion bejegyzés és írd át nagyobbra. Pl:
    &lt;!-- Firefox --&gt;<br />
    .<br />
    .<br />
    &lt;em:maxVersion&gt;<strong>7.*.*</strong>&lt;/em:maxVersion&gt;<code></li><br />
    <li>Indítsd újra a Firefoxot</li><br />
    </ol></p>
    <p>Ha a bővítmény esetleg <strong>valamilyen.xpi</strong> fájl (tehát nincs külön alkönyvtára), akkor sem veszett az ügy.<br />
    Az <strong>xpi</strong> fájlok lényegében <strong>zip</strong>-ek, tehát csak ki kell csomagolni őket valahova, majd a fenti módosítások után újra összecsomagolni (figyelve, hogy .xpi végződést kapjanak) és máris lehet telepíteni őket.</p>
    <p><em>Természetesen nincs garancia arra, hogy minden bővítmény hiba nélkül használható ez után is (hiszen nem véletlenül nőtt a Firefox verziója), de az esetek nagy részében szerintem nem lesz gond.</em>